将 MikroTik 的 mAP lite 设置为 cpe 模式

这个小东西有 1 个无线网卡和 1 个以太网口,默认模式是 ap。如果是作为 ap 来用有点大材小用,淘宝有大把的 ap 且比这个便宜。如果是作为 cpe 来用,就没有多少产品能这么干了,想象一下以太网接口的无线网卡,是不是很另类。

cpe 模式简单来说就是作为客户端设备去连某个 ap,并将网口桥接到 ap 上,可为没有无线网卡的设备(比如只有以太网口的网络摄像机、没有无线网卡的电脑、路由器的 WAN 口、只有以太网口的打印机等)提供连接 ap 的能力,方便这些设备联互联网。

当然,如果能很容易把这个小东西设置成 cpe 模式,我就不写这个文章了。

虽然能够直接在 web 管理界面的 quick set 里头选择 cpe 模式,但初始化设置时要先连这个小东西的 ap,但是在 cpe 模式中连接别的 ap 就会断开现有的 ap 连接,然后就啥也干不了了。虽然我曾经阴差阳错捣鼓到能用的程度,但在掌握到窍门前,每次设置都是曲折的, 而且设置过后无法再用 winbox 连接修改设置,更不幸的是,一段时间过后我连这阴差阳错捣鼓出来的方法都忘掉了。 所谓的窍门来源于这个官网论坛帖子,但是有点不明确,估摸着设置可能无法真正把以太网口桥接到 ap 上…下面是可用的设置步骤,防止我再忘掉。

  1. 假定 mAP lite 新开箱,通过 mAP lite 提供的 ssid 连接到管理 web 页面,这个说明书上有。如果不是新开箱,最好物理 reset 一下先。
  2. 别的啥都别搞,在设置页面上选择 WebFig,然后 system->Reset configuration,勾上 No Default Configuration,然后重置设置。
  3. 等 mAP lite 重启完成,用网线把 mAP lite 连到电脑上,用 winbox 查找到设备并点选 MAC 地址登录,用户名是 admin,密码为空。
  4. 在 Bridge 中新建一个桥接,然后把 wlan1 和 ether1 两个端口都添加到这个桥接中。
  5. 在 IP->DHCP Client 中新建一个 DHCP 客户端,界面选择刚新建的桥接。
  6. 在 Wireless 中将 wlan1 的模式设置为 station pseudobridge,输入需要连接 ap 的 ssid ,选择对应的 Security Profile(需先设置好需要的 security profile),选择合适的 Band(比如 2GHz-B/G/N,默认的 2GHz-B/G 可能连不上某些 ap)。

官网论坛帖子不太明确的地方是讲要把 wireless 设成 client,但这个设备并没有一个写成 client 的模式。我设置过 station 模式,提示连上 ap 但是数据通不了。后来尝试在设了 station 模式过后,在 quick set 里选 cpe 模式保存了一下(换到 quick set 就默认选中 cpe 了,我啥也没改就点了一下保存)数据就能通了。核对参数变化,发现模式从 station 变成了 station pseudobridge,这俩模式的解释可以参考官方的 wiki 页面,可能论坛帖子讲的 client 就是 station pseudobridge 的俗称,我这种外行捣鼓这些东西很容易被迷惑。用这种方法修改后可以随时用 winbox 连接并修改配置(比如新的 ssid)。

宜可编辑如下文档(假定文件名为as_cpe.rsc),在完成上面第3步过后,在 Files 里上传该文档,然后在 New terminal 里执行 /import file=as_cpe.rsc,重启后即可生效。记得把 YOUR_SSID 和 YOUR_PASSWD 换成自己要连的 ap。这堆东西是执行 /export file=as_cpe.rsc 搞出来的。

/interface bridge
add name=bridge1
/interface wireless security-profiles
add authentication-types=wpa-psk,wpa2-psk eap-methods="" \
    management-protection=allowed mode=dynamic-keys name=YOUR_SSID \
    supplicant-identity="" wpa-pre-shared-key=YOUR_PASSWD wpa2-pre-shared-key=\
    YOUR_PASSWD
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no mode=station-pseudobridge \
    security-profile=YOUR_SSID ssid=YOUR_SSID
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether1
/ip dhcp-client
add disabled=no interface=bridge1

ps. 为啥不一开始就用 winbox,主要是因为默认的初始化设置只让通过无线连接到 mAP lite,从以太网口用 winbox 连不上,所以先在 WebFig 里头重设配置,同时去掉默认配置,使得能通过以太网用 winbox 连接 mAP lite。

ps. 由于第 2 步重置了设备并删除了默认设置,设备两个端口都没有被分配 IP,故需要用 winbox 通过 MAC 地址连接登录。

说点啥呗

电子邮件地址不会被公开。 必填项已用*标注